Les Fonctions logiques

MARKDOWN.WMF (4790 octets)

Les fonctions logiques

Les fonctions logiques permettent d'introduire des tests dans les tableaux, afin de vérifier si une condition définie par l'utilisateur a été remplie. Par exemple vérifier si un certain seuil a été dépassé, ou faire effectuer un calcul en fonction d'une donnée prédéfinie.

Les opérateurs des fonctions logiques disponibles sont les suivants:

 

Retour en haut


La fonction SI (Test simple)

Nous aimerions qu'Excel nous avertisse dés qu'une certaine valeur est atteinte, par exemple en affichant un message d'avertissement. Nous demandons à Excel d'effectuer un test logique. c. à d. nous lui demandons de tester si une condition déterminée est remplie ou non lorsqu'on effectue une mise à jour de la saisie d'une valeur. (En termes informatiques la réponse pourra être soit VRAI soit FAUX).

Pour effectuer ce test nous allons utiliser la fonction SI.

La syntaxe de la fonction SI est composée de trois arguments:


=SI(test_logique;valeur_si_vrai;valeur_si_faux)

  • L'argument test_logique: est la condition qui doit être remplie, c.à d. toute valeur dont le résultat peut être vrai ou faux. (p. ex. un seuil dépassé; valeur>100)
  • L'argument valeur_si_vrai est la valeur ou l'action qui doit être affichée ou exécutée si la condition du test logique est remplie.
  • L'argument valeur_si_faux est la valeur ou l'action qui doit être affichée ou exécutée si la condition du test logique n'est pas remplie.

 


Exemple pratique:

Vous gérez votre stock de marchandises et vous aimeriez qu'Excel vous avertisse dès qu'un seuil déterminé soit franchi. P. exemple dès que vous avez moins de 200 unités de chaque produit. Si la quantité en stock se situe en dessous de 200 unités il faudra qu'Excel affiche le message d'avertissement suivant: "Stock trop faible".

La formule à insérer dans la colonne Message d'avertissement est la suivante:

  A B C D E
1 Produit Quantité reçue Quantité vendue Quantité en stock Message d'avertissement
2 Cahiers 1200 500 700 =SI(D2<200;"Stock trop faible";"")
3 Crayons 500 200 300  
4 Bloc Notes 400 300 100  
5 etc.        

Explication:

=SI(Quantité_en_stock<200;"Stock trop faible";" ")

Quantité_en_stock<200 = test logique (la condition qui doit être remplie)

"Stock trop faible" = Message d'avertissement qui s'affiche si la condition est remplie (VRAI)

" " = espace vide si la condition n'est pas remplie (FAUX)

Retour en haut


Les tests imbriqués:

Pour tester plusieurs conditions il est possible d'imbriquer plusieurs tests dans une séquence logique: Par exemple, appliquer deux taux de rabais en fonction de deux montants d'achat différents: (p. ex. à partir de 300.-- d'achat vous appliquez un rabais de 5% et à partir de 500.-- un rabais de 8%).

La fonction contenant les deux tests logiques imbriqués aura la syntaxe suivante:

=SI(Test_logique1;Valeur_si_vrai1;SI(Test_logique2;Valeur_si_vrai2;Valeur_si_faux))

  A B C D E
1 Produit Prix de vente Quantité vendue Prix total Rabais?
2 Cahiers 2.00 500 1000.00 =SI(D2>500;D2*8%;SI(D2>300;D2*5%;"pas de rabais"))
3 Crayons 1.00 400 400.00  
4 Bloc Notes 2.00 100 200.00  
5 etc.        

NB: Il faudra prêter une attention particulière à l'ordre chronologique dans lequel vous imbriquez les tests, pour éviter qu'une condition ne soit pas déjà reprise au préalable par un autre test. Dans notre cas le fait de tester d'abord les montants >300 pour accorder le rabais de 5%, rendrais un deuxième test sur des montants dépassant 500.-- inutile car ces valeurs auraient déjà été reprises par le premier test (500 étant plus grand que 300....!)

Retour en haut


Les Tests élaborés avec les opérateurs ET et OU

Les opérateurs logiques ET et OU permettent de créer des tests plus nuancés ou restrictifs. Il s'agit ici de tests logiques qui permettent de tenir compte de plusieurs conditions, qui peuvent intervenir.

L'opérateur OU permet de nuancer le test en tenant compte de conditions qui peuvent intervenir sans s'exclure mutuellement.

L'opérateur ET permet de  restreindre le test logique à des conditions qui doivent être remplie impérativement

Les deux tables de vérité suivantes donnent une synthèse sur les différentes possibilités de ces opérateurs:

Voici les quatre possibilités pour l'opérateur OU et les résultats respectifs:

1ère condition   2ème condition Résultat
remplie (VRAI) OU remplie (VRAI) VRAI
non remplie (FAUX) OU remplie (VRAI) VRAI
remplie (VRAI) OU non remplie (FAUX) VRAI
non remplie (FAUX) OU non remplie (FAUX) FAUX

Voici les quatre possibilités pour l'opérateur ET et les résultats respectifs:

1ère condition   2ème condition Résultat
remplie (VRAI) ET remplie (VRAI) VRAI
non remplie (FAUX) ET remplie (VRAI) FAUX
remplie (VRAI) ET non remplie (FAUX) FAUX
non remplie (FAUX) ET non remplie (FAUX) FAUX

Les syntaxes des opérateurs logique ET et OU:

ET =SI(ET(1ère condition;2ème condition);Valeur si vrai;Valeur si faux)
OU =SI(OU(1ère condition;2ème condition);Valeur si vrai;Valeur si faux)

Retour en haut


Retour à la page d'accueil

 

© 2016 E. Matafora