landing page templates

LES FONCTIONS LOGIQUES (SI, ET, OU)

Les fonctions logiques permettent d'introduire des tests dans les tableaux, afin de vérifier si une condition définie par l'utilisateur a été remplie ou non. Par exemple vérifier si un certain seuil a été dépassé, ou faire effectuer un calcul en fonction d'une donnée ou d'un résultat obtenu.

Les opérateurs des fonctions logiques:

 - SI (tests simples et tests imbriqués)

 - ET et OU (tests élaborés)

La fonction SI (Test simple)

Nous aimerions qu'Excel nous avertisse dés qu'une certaine valeur est atteinte, par exemple en affichant un message d'avertissement. Nous demandons à Excel d'effectuer un test logique. c. à d. nous lui demandons de tester si une condition déterminée est remplie ou non lorsqu'on effectue une mise à jour de la saisie d'une valeur. (En termes informatiques la réponse pourra être soit VRAI soit FAUX).

Pour effectuer ce test nous allons utiliser la fonction SI.

La syntaxe de la fonction SI est composé de trois arguments:

=SI(test_logique;valeur_si_vrai;valeur_si_faux)

• L'argument test_logique : est la condition qui doit être remplie, c.à d. toute valeur dont le résultat peut être vrai ou faux. (p. ex. un seuil dépassé; valeur>100)

• L'argument valeur_si_vrai : est la valeur ou l'action qui doit être affichée ou exécutée si la condition du test logique est remplie.

• L'argument valeur_si_faux : est la valeur ou l'action qui doit être affichée ou exécutée si la condition du test logique n'est pas remplie.

Exemple :

Vous gérez votre stock de marchandises et vous aimeriez qu'Excel vous avertisse dès qu'un seuil déterminé soit franchi. Par exemple, dès que vous avez moins de 200 unités de chaque produit.

Si la quantité en stock descend en dessous de 200 unités, il faudra qu'Excel affiche le message d'avertissement suivant: "Stock trop faible".

La syntaxe de la formule à insérer dans la colonne Message d'avertissement serait la suivante:

=SI(Quantité en stock<200;afficher "Stock trop faible";sinon "ne rien afficher")

ce qui donne dans la cellule E2 : =SI(D2<200:"Stock trop faible";"")

Explication :

=SI(D2<200;"Stock trop faible";"")

• D2<200 = test logique (la condition qui doit être remplie)

• "Stock trop faible" = Message d'avertissement qui s'affiche si la condition est remplie (VRAI)

• " " = espace vide si la condition n'est pas remplie (FAUX)

Donc si la condition est remplie Excel affiche le message "Stock trop faible"

L'exemple en vidéo


Voici quelques autres vidéos avec divers exemple de tests logiques:

Fonctions SI imbriquées (Excel 2007)

Tests logiques imbriqués et mise en forme conditionnelle
Test logique avec les fonctions SI et ET

EXCEL ONLINE
Formation Excel en ligne 

CONTACTS
Email: info@excel-online.net